D-Link

DWR-M920VB

4G LTE N300 Battery Router with Voice

  • WAN port to connect to the Internet
  • One 10/100 Ethernet LAN port to connect wired devices for high-speed activities
  • SIM card slot for a mobile broadband connection
  • Supports VoLTE & CS Voice
  • Wireless 802.11 b/g/n
  • Supports WPA/WPA2/WPA3, and WPA-PSK/WPA2-PSK encryption
  • Dual-active firewalls (NAT/SPI) to control traffic and prevent exploits and intrusions

Overview

D-Link's DWR-M920VB 4G N300 LTE Router allows you to access mobile broadband networks from anywhere. Once connected, you can check e-mail, surf the web, and stream media. Use your carrier's SIM/UICC card to share your 3G/4G Internet connection through a secure wireless network or by using the 10/100 Ethernet port.

Global Mobile Broadband

3G/4G mobile connectivity lets you take your broadband connection with you wherever you go

High-speed Connectivity

Enjoy high-speed wireless IEEE 802.11n with speeds of up to 300 Mbps, so that you can access the Internet and transfer data quickly

Strong Security and Encryption

A variety of powerful, yet easy to set up VPN security tools keep connections private and secure at all times.

Fast Mobile Internet

The DWR-M920VB lets you connect to your 3G/4G mobile connection with fast downlink speeds of up to 150 Mbps and uplink speeds up to 50 Mbps, giving you the speed you need for fast, responsive Internet access. Surf the web with ease and stream music and video over the Internet to your PCs and mobile devices.

Secure Wired and Wireless Connections

The DWR-M920VB utilizes dual-active firewalls (SPI and NAT) to prevent potential attacks across the Internet. Industry standard WPA/WPA2/WPA3 wireless encryption keeps your wireless network secure and your traffic safe, allowing you to share your 3G/4G connection without worrying about unauthorized users accessing your network.

Easy to Set Up and Use

The DWR-M920VB can be installed quickly and easily almost anywhere. It can be configured through almost any web browser without the need for special software. This router makes it possible to stay connected, even when conventional broadband services are unavailable.

DWR-M920VB

Specifications

Specification
ChipsetASR1803
Memory1Gbits ROM + 1Gbits RAM (built-in)
Wi-Fi ChipsetRTL8192ES
LEDPower Indication LED*1 Battery Status LED*1 WAN Status LED*1 Net Indication LED*1 WiFi Indication LED*1 LAN Status LED*1 Signal Strength*4 WPS Indication LED*1 Phone Status LED*1
ButtonsPower, WPS
Pin HoleReset
EthernetRJ45 x 2 (1 WAN + 1 LAN, 10BaseT/100Base Automatic Adaptive Port)
RJ11RJ11*1
Battery5000mAh
Wi-Fi Antenna2 x 3dBi internal antenna
LTE Antenna2 x 5dBi external antenna
DWR-M920VBFDD: B1/B3/B5/B7/B8/B20/28 TDD: B38/40/41 WCDMA: B1/B5/8
Standards802.11b/g/n 2.4 ~ 2.4835GHz Korea, Japan, ETSI, FCC channels can be selected
Modulation SchemesOFDM = BPSK, QPSK, 16-QAM, 64-QAM DSSS = DBPSK, DQPSK, CCK
Transfer RateHT20: up to 144 Mbps HT40: up to 300 Mbps
GeneralRFC0768 UDP RFC0791 IP RFC0792 ICMP RFC0793 TCP RFC0826 Ethernet ARP RFC0894 IP Over Ethernet RFC0922 Broadcasting Internet Datagrams RFC0950 Internet Standard Subnetting IEEE802.3 Ethertype IEEE802.11b IEEE802.11g IEEE802.11n RFC2516 PPP Over Ethernet (PPPoE) RFC1662 PPP in HDLC-like Framing RFC1332 PPP Internet Protocol Control Protocol RFC1042 A standard for the Transmission of IP Datagrams over IEEE 802 Networks IPoE (a.k.a IP over Ethernet AAL5) DHCP server, client NAT, NAPT and ALG DMZ and Port forwarding (Virtual Server) PPTP, L2TP VPN Pass Through Logs and Statistics TR-069 Remote Management Flexible and secure SPI Firewall, Denial of Service (DoS) protection Port Filtering, IP Filtering and MAC Filtering URL Filter DDNS IPV6 Static Route SNTP Date/Time update from Internet Time Server ETH WAN link-backup via 3G/4G Module WEB GUI Embedded AP with 2 SSIDs Wireless client mode Separate Authentication for each SSID 802.1Q VLAN SMS USSD VoLTE and CS
Operating Temperature-10°C ~ 55°C
Storage Temperature-40°C ~ 85°C
Operating Humidity5% ~ 95% (typical)
Power Supply12V/1A
Regulation ComplianceCCC CE FCC
Safety RegulationsUL
Green StandardRoHS

Actual performances may vary due to settings, cabling, temperature, network configuration, interface, device compatibility, environmental and on-site conditions, and other similar factors. References to power capability, signal or processing speed, signal range or distance, data encryption, storage capacity, display properties, or other performance metrics are based on optimal conditions derived from industry standards and provided for informational purposes only. Specifications may be subject to change without prior notice.

Support

Downloads

Datasheets
DescriptionDateTypeFile SizeDownload
DatasheetDatasheetPDF · 0.73mb-PDF0.73mb